Rabu, 28 Maret 2012

KONFIGURASI VLAN, ROUTING STATIC, DHCP DAN NAT PADA LAYER 3 SWITCH CISCO 3560

Layer 3 switch atau Multilayer Switch adalah switch yang bekerja pada layer 2 dan juga bekerja pada layer 3 yang mempunyai fungsi routing, kemampuan routing pada layer 3 switch antara lain routing antar VLAN berdasarkan encapsulation dot 1Q maupun routing protocol static dan routing protocol dinamis lain seperti Border Gateway Protocol (BGP), Enhanced Interior Gateway Routing Protocol (EIGRP), Open Shortest Path First (OSPF), dan Routing Information Protocol (RIP). Pada contoh ini akan diperlihatkan langkah melakukan konfigurasi VLAN pada Catalyst 3560 serta routing antar VLAN, Routing Static, DHCP dan juga NAT.
Skenario

VLAN ID Nama VLAN Alamat Subnet
2 Guest 192.168.0.0/24
3 Student 192.168.1.0/24
4 Lecture 192.168.2.0/24
Interface IP address
Interface vlan 2 192.168.0.1/24
Interface vlan 3 192.168.1.1/24
Interface vlan 4 192.168.2.1/24
Interface gigabitEthernet 0/1 222.124.194.2/27
Topologi
layer-3-switch
Buat Database VLAN pada Switch.
Switch>enable
Switch#vlan
Switch#vlan database
Switch(vlan)#vlan 2 name guest
VLAN 2 added:
Name: guest
Switch(vlan)#vlan 3 name student
VLAN 3 added:
Name: student
Switch(vlan)#vlan 4 name lecture
VLAN 4 added:
Name: lecture
Switch(vlan)#exit
APPLY completed.
Exiting….
Switch#
Masuk ke Global Configuration Mode dan lakukan Grouping Port.
Switch#configure terminal
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 4
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/6
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 4
Switch(config-if)#
Buat Interface VLAN yang berfungsi sebagai gateway tiap-tiap VLAN, Nomor Interface VLAN yang dibuat harus sama VLAN ID yang akan dilewatkan, misalnya interface VLAN 2 itu berfungsi sebagai gateway untuk VLAN 2, begitu juga dengan VLAN yang lain.
Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.0.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 3
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 4
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#
Untuk memudahan pemberian IP address pada host tiap-tiap VLAN ada baiknya kita membuat DHCP server, dan pada contoh ini kita akan menggunakan IP 222.124.194.11 sebagai DNS server
Switch(config)#ip dhcp pool vlan2
Switch(dhcp-config)#default-router 192.168.0.1
Switch(dhcp-config)#dns-server 222.124.194.11
Switch(dhcp-config)#network 192.168.0.0 255.255.255.0
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool vlan3
Switch(dhcp-config)#default-router 192.168.1.1
Switch(dhcp-config)#dns-server 222.124.194.11
Switch(dhcp-config)#network 192.168.1.0 255.255.255.0
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool vlan4
Switch(dhcp-config)#default-router 192.168.2.1
Switch(dhcp-config)#dns-server 222.124.194.11
Switch(dhcp-config)#network 192.168.2.0 255.255.255.0
Switch(dhcp-config)#exit
Switch(config)#
Berikan IP address pada Interface gigabitEthernet 0/1 (anda bisa mengguakan interface lain jika tidak menggunakan interface ini), perhatikan perintah no switchport , perintah ini digunakan agar interface tersebut itu bisa diberi IP address seperti halnya pada router atau interface layer 3, tanpa perintah ini maka interface pada switch hanya sebagai interface layer 2.
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 222.124.194.2 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Buat default routing yang berfungsi sebagai “the last resort” terhadap tujuan packet dalam menuju alamat yang tidak terdapat pada routing tabel, sehingga packet tidak di-dischard atau dibuang dari network.
Switch(config)#ip route 0.0.0.0 0.0.0.0 222.124.194.1
Buat NAT sehingga IP private yang berada pada VLAN bisa ditranlasi menuju IP Public, masuk ke interface gigabitEthernet 0/1 dan setting sebgai NAT Outside, kemudian masuk ke tiap-tiap Interface VLAN yang sudah kita buat dan set sebagai NAT Inside.
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#ip nat outside
Switch(config-if)#exit
Switch(config)#interface vlan 2
Switch(config-if)#ip nat inside
Switch(config-if)#exit
Switch(config)#interface vlan 3
Switch(config-if)#ip nat inside
Switch(config-if)#exit
Switch(config)#interface vlan 4
Switch(config-if)#ip nat inside
Switch(config-if)#exit
Switch(config)#
Kemudian buat aturan NAT dan jangan lupa untuk mengatur access-list agar mengizinkan packet untuk lewat, perhatikan juga nomor aturan NAT dan access-list keduanya harus mempunya nomor yang sama, jadi kalau aturan NAT-nya menggunakan nomor 1 maka pada access-list juga harus menggunakan nomor 1.
Switch(config)#ip nat inside source list 1 interface gigabitEthernet 0/1 overload
Switch(config)#access-list 1 permit any
Switch(config)#
Kembali ke Privilege Mode dan simpan hasil konfigurasian
Switch(config)#exit
Switch#copy running-config startup-config
Switch#

Reaksi:

0 komentar:

Poskan Komentar